PTA乙级 1044 C语言实现
题目
火星人是以 13 进制计数的:
地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
C语言实现
来自大佬的代码
#include<stdio.h>
#include<stdlib.h>
#include<ctype.h>
#include<string.h>
/* strcmp 比较两个字符串 头文件string.h
若str1=str2,则返回零;若str1>str2,则返回正数;若str1<str2,则返回负数。
%*c 读入\n,否则后面读入的将一直是\n。
"*"表示该输入项读入后不赋予任何变量,即跳过该输入值。*/
char mars1[13][4]={"","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
char mars2[13][5]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
void tomars(int num){
int sp1=num/13,sp2=num%13;
if(sp1)
printf("%s",mars1[sp1]);
if(sp1&&sp2)
putchar(' ');
if((!sp2&&!sp1)||sp2)
printf("%s",mars2[sp2]);
putchar('\n');
return;
}
void toearth(char *str){
int sum=0;
char temp[4]="",temps[5]="";
sscanf(str,"%s%s",temp,temps);
int sp1,sp2;
for(int i=1;i<=12;i++)
if(!strcmp(mars1[i],temp)){
sum+=i*13;
break;
}
for(int i=0;i<=12;i++)
if(!strcmp(mars2[i],temps)||!strcmp(mars2[i],temp)){
sum+=i;
break;
}
printf("%d\n",sum);
return;
}
int main(){
int cnt;
scanf("%d",&cnt);
while(cnt--){
char str[20]={0};
scanf("%*c%[^\n]",str);
if(isdigit(str[0])){
int num;
sscanf(str,"%d",&num);
tomars(num);
}
else
toearth(str);
}
return 0;
}
精妙的points
- 用二维数组储存火星文
- 用strcmp比较两数组大小
- 输入时两位之间有空格,所以利用sscanf函数将其分为两个数组sscanf函数详解
- isdigit函数详解
- if(!a||!b)表示至少有一个非零
if(!a&&!b)表示全为零
if(a==0)即if(! a)