C pta实验八 线性表

一、函数题

1 顺序表操作集

本题要求实现顺序表的操作集。

函数接口定义:

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

其中List结构定义如下:

typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

各个操作函数的定义为:

List MakeEmpty():创建并返回一个空的线性表;

Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;

bool Insert( List L, ElementType X, Position P ):将X插入在位置P并返回true。若空间已满,则打印“FULL”并返回false;如果参数P指向非法位置,则打印“ILLEGAL POSITION”并返回false;

bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“POSITION P EMPTY”(其中P是参数值)并返回false。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define MAXSIZE 5
#define ERROR -1
typedef enum {false, true} bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
    ElementType Data[MAXSIZE];
    Position Last; /* 保存线性表中最后一个元素的位置 */
};

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

int main()
{
    List L;
    ElementType X;
    Position P;
    int N;

    L = MakeEmpty();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        if ( Insert(L, X, 0)==false )
            printf(" Insertion Error: %d is not in.\n", X);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &X);
        P = Find(L, X);
        if ( P == ERROR )
            printf("Finding Error: %d is not in.\n", X);
        else
            printf("%d is at position %d.\n", X, P);
    }
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &P);
        if ( Delete(L, P)==false )
            printf(" Deletion Error.\n");
        if ( Insert(L, 0, P)==false )
            printf(" Insertion Error: 0 is not in.\n");
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

6
1 2 3 4 5 6
3
6 5 1
2
-1 6

输出样例:

FULL Insertion Error: 6 is not in.
Finding Error: 6 is not in.
5 is at position 0.
1 is at position 4.
POSITION -1 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.
POSITION 6 EMPTY Deletion Error.
FULL Insertion Error: 0 is not in.
List MakeEmpty()/* 建立一个空表 */
{
    List L = (List)malloc(sizeof(struct LNode));
    L->Last = -1; /* 表的最后位置默认为-1 */
    return L;
}
Position Find( List L, ElementType X )
{
    for(int i=0; i<=L->Last; i++)
    {
        if(L->Data[i] == X) /* 找到元素就返回位置 */
            return i;
    }
    return ERROR; /* 遍历完未找到X则返回ERROR */
}
bool Insert( List L, ElementType X, Position P )
{
    if(L->Last == MAXSIZE-1) /* 顺序表满的情况输出FULL */
    {
        printf("FULL");
        return false;
    }
    else if(P<0 || P>L->Last+1) /* 插入的位置为【0, last+1】才能保证表的连续,不然则输出“非法地址” */
    {
        printf("ILLEGAL POSITION");
        return false;
    }
    else/* 可以插入的情况 */
    {
        for(int i=L->Last+1; i>P; i--)
        {
            L->Data[i] = L->Data[i-1]; /* 将P及其后的元素都往后位移一格 */
        }
        L->Data[P] = X; /* 插入 */
        L->Last++;
        return true;
    }
}
bool Delete( List L, Position P )
{
    if(P<0 || P>L->Last)	/* 删除的位置为【0, last+1】才能保证表的连续 */
    {
        printf("POSITION %d EMPTY",P);
        return false;
    }
    else
    {
        for(int i=P;i<L->Last;i++) /* 把后面的元素往前移一位实现删除 */
        {
            L->Data[i] = L->Data[i+1];
        }
        L->Last--; /* 最后位减一 */
        return true;
    }
}

二、编程题

2 最长连续递增子序列

给定一个顺序存储的线性表,请设计一个算法查找该线性表中最长的连续递增子序列。例如,(1,9,2,5,7,3,4,6,8,0)中最长的递增子序列为(3,4,6,8)。

输入格式:

输入第1行给出正整数n(≤105);第2行给出n个整数,其间以空格分隔。

输出格式:

在一行中输出第一次出现的最长连续递增子序列,数字之间用空格分隔,序列结尾不能有多余空格。

输入样例:

15
1 9 2 5 7 3 4 6 8 0 11 15 17 17 10

输出样例:

3 4 6 8
#include<stdio.h>
struct node
{
    int b;
    int k;
}
s[100001];  // 这里一定要注意是100001 而不是10000
 
int main()
{
int i,j;
int n;
int maxi=1,c;
scanf("%d",&n);
for(i=0;i<n;i++){
    scanf("%d",&s[i].b);
    s[i].k=1;
}
for(i=0;i<n-1;i++)
{
    for(j=i+1;j<n;j++)
    {
        if(s[j].b>s[j-1].b)
            s[i].k++;
        else
        {
          i = j-1; //
          break;
        }
    }
}
for(i=0;i<n;i++)
{
    if(s[i].k>maxi)
    {
        maxi=s[i].k;
        c=i;
    }
}
for(i=c;i<c+maxi-1;i++)
    printf("%d ",s[i].b);
printf("%d\n",s[c+maxi-1].b);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星辰微澜316

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值