Description
一只老鼠有M磅猫食,然后在N个房间里面用猫食换JavaBean,房间i中能用F[i]磅的猫食换J[i]磅的JavaBean,而且老鼠可以在一个房间里根据一定比例a%来换取JavaBean.
现在他是这任务分配给你:告诉他,他的JavaBeans的获取能最多。
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1′s. All integers are not greater than 1000.
M是开始时老鼠有的猫食!
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
#include <bits/stdc++.h>
using namespace std;
struct st
{
int a,b;
double c;
}s[1005];
bool cmp(st x,st y)
{
if(x.c!=y.c) return x.c>y.c;
else return x.b>y.b;
}
int main()
{
int m,n,i;
double ans;
while(cin>>m>>n)
{
ans=0;
if(m==-1&&n==-1)
break;
for(i=1;i<=n;i++)
{
cin>>s[i].a>>s[i].b;
s[i].c=(double)s[i].a/(double)s[i].b;//必须改变类型
}
sort(s+1,s+n+1,cmp);
for(i=1;i<=n;i++)
{
if(m>s[i].b)
{
m-=s[i].b;
ans+=s[i].a;
}
else
{
ans+=m*s[i].c;
break;
}
}
printf("%.3lf\n",ans);
}
return 0;
}