HDUOJ 2069 Coin Change
Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.
For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.
Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
Sample Input
11
26
Sample Output
4
13
最简单的方法就是暴力几组for循环也可解出来,但题目明显不是要考查这个
实质是完全背包问题,我也不太懂,参考博客题解
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[5] = { 1,5,10,25,50 }; ///表示5种硬币各自的价值
int dp[110][260];///表示dp[i][v] 用i个硬币凑成价值为v的方法数
int main()
{
int n;
while (cin >> n)
{
memset(dp, 0, sizeof(dp)); //初始化dp数组
dp[0][0] = 1;///边界
for (int i = 0; i < 5; i++)
{
for (int k = 1; k <= 100; k++) //k个硬币
{
for (int v = a[i]; v <= n; v++)
{
dp[k][v] += dp[k - 1][v - a[i]];//状态转移方程
}
}
}
int ans = 0;
for (int i = 0; i <= 100; i++)
{
ans += dp[i][n];
}
cout << ans << endl;
}
return 0;
}