Strategic game
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?
Your program should find the minimum number of soldiers that Bob has to put for a given tree.
For example for the tree:
the solution is one soldier ( at the node 1).
Input
The input contains several data sets in text format. Each data set represents a tree with the following description:
the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roads
or
node_identifier:(0)
The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.
Output
The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:
Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Sample Output
1
2
题意:就是在一棵树里,要在一些点上放守卫, 每个守卫可以守护这个点上的边, 问最少放多少个守卫能守护所有的点
dp[i][0]=0表示不放
d[i][1]=1表示放
思路:
如果i是叶子节点的话,放dp[i][0] = 0; dp[i][1] = 1;
不为叶子节点时,
dp[x][0]+=dp[i][1];
dp[x][1]+=min(dp[i][0],dp[i][1]);
其中i为x的子节点。
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n;
int father[1505];
int dp[1505][2];
int root;
int vis[1505]= {0};
void dfs(int x)
{
vis[x]=1;
for(int i=0; i<n; i++)
{
if(father[i]==x&&vis[i]==0)
{
dfs(i);
dp[x][0]+=dp[i][1];
dp[x][1]+=min(dp[i][0],dp[i][1]);
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(father,-1,sizeof(father));
memset(vis,0,sizeof(vis));
for(int i=0; i<n; i++)
{
int l;
scanf("%d",&l);
getchar();
getchar();
int num;
scanf("%d",&num);
getchar();
getchar();
for(int j=0; j<num; j++)
{
int k;
scanf("%d",&k);
father[k]=l;
}
}
for(int i=0; i<n; i++)
if(father[i]==-1)
root=i;
// printf("%d$\n",root);
for(int i=0; i<n; i++)
{
dp[i][0]=0;
dp[i][1]=1;
}
dfs(root);
printf("%d\n",min(dp[root][0],dp[root][1])); }