Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1k1×p2k2×⋯×pmkm.
Input Specification:
Each input file contains one test case which gives a positive integer N in the range of long int.
Output Specification:
Factor N in the format N =
p1^
k1*
p2^
k2*
…*
pm^
km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.
Sample Input:
97532468
结尾无空行
Sample Output:
97532468=2^2*11*17*101*1291
结尾无空行
/*思路:素数打表*/
#include <bits/stdc++.h>
using namespace std;
const int maxv=100010;
int prime[maxv],num=0;
struct numx
{
int x,cnt;
};
bool judge(int n)
{
if(n<2) return false;
for(int i=2;i*i<=n;i++) if(n%i==0) return false;
return true;
}
void find_prime()
{
for(int i=2;i<maxv;i++)
{
if(judge(i)) prime[num++]=i;
}
}
int main()
{
int n;
vector<numx> v;
scanf("%d",&n);
find_prime();
if(n==1) printf("1=1\n");
else
{
printf("%d=",n);
int sqr=(int)sqrt(n*1.0);
for(int i=0;prime[i]<=sqr;i++)
{
if(n%prime[i]==0)
{
numx temp;
temp.x=prime[i];
temp.cnt=0;
while(n%prime[i]==0)
{
temp.cnt++;
n/=prime[i];
}
v.push_back(temp);
if(n==1) break;
}
}
}
if(n!=1) v.push_back({n,1});
for(int i=0;i<v.size();i++)
{
if(v[i].cnt>1) printf("%d^%d",v[i].x,v[i].cnt);
else printf("%d",v[i].x);
if(i!=v.size()-1) printf("*");
}
return 0;
}