魔咒问题

题面:

魔咒词典中有很多魔咒,他们的格式:[魔咒] 对应功能

现在共有 N 个问题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能

你需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,就输出 “what?”

输入首先列出魔咒词典中不超过100000条不同的咒语,每条格式为: [魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。

词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

sample input:

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

sample output:

light the wand
accio
what?
what?

思路:
  • 这道题是一个对字符串进行哈希的题目,使用bkdr将一串字符串进行哈希转为一串数字
  • seed常用7,17,131或者其他质数,mod常见取值用1e9+7或采用unsigned long long 自然溢出(相当于%264)
  • 举例字符串aed : (1 x seed3+5 x seed2 + 4 x seed1)%mod
  • 使用bkdr的特点是,字符变化和两个字符串合并都可以使用 o(1) 来修改哈希值,可用于快速查询一个串是否出现过,快速比较两个串是否相同。同时给定hash值无法还原字符串,比较安全。
  • 本题使用两个map进行映射,map[hash1] = index, s1[index] = 魔咒 ;map[hash2] = index, s2[index] = 对应功能
  • 对于每一次的查询都首先用 ‘ [ ’ 来判断给定的是魔咒还是对应的功能,然后在对应的map中进行查询
  • 因为可能会出现其他字符,所以减 ’ ’ 来保证每一个字符都能找到对应的asc码来计算对应的hash值
  • 需要注意读入空格的问题和读入功能有空格的时候应该用getline来读入
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<map> 
using namespace std;
const int seed=17;
char mz[100001][30],gn[100001][100];
map<unsigned long long ,int>m,g;
int hashash(char *str)
{
 int sum=0;
 int sed=1;
 int len=strlen(str);
 for(int i=0;i<=len;i++)
 {
  sed*=seed;
  sum+=(str[i]-' ')*sed;
 }
 return sum;
}
int main()
{
 string str1,str2,str3;
 int tot=0,n=0;
 char q[1001];
 while(cin>>str1)//遇到空格停止 
 {
  //if(strcmp(str1,'@END@')==0)
  //c++允许直接== 
  if(str1=="@END@")
   break;
  tot++;
  getline(cin,str2);
  strcpy(mz[tot],str1.c_str());
  strcpy(gn[tot],str2.c_str()+1);
  m[hashash(mz[tot])]=tot;
  g[hashash(gn[tot])]=tot;
 }
 scanf("%d",&n);
 getchar();
 for(int i=0;i<n;i++)
 {
  getline(cin,str3);
  strcpy(q,str3.c_str());
  unsigned long long temp=hashash(q);
  if(q[0]=='[')//判断是什么内容的查询 
  {
   if(m.find(temp)==m.end())
    cout<<"what?"<<endl;
   else cout<<gn[m[temp]]<<endl;
  }
  else
  {
   if(g.find(temp)==g.end())
    cout<<"what?"<<endl;
   else
   {
    for(int i=1;i<strlen(mz[g[temp]])-1;i++)
     cout<<mz[g[temp]][i];
    cout<<endl;
   }
  }
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值