专栏:PAT乙级刷题笔记
题目
给定一个长度不超过 1 0 4 10^4 104的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest… 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式
输入在一行中给出一个长度不超过 1 0 4 10^4 104的、仅由英文字母构成的非空字符串。
输出格式
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例
redlesPayBestPATTopTeePHPereatitAPPT
输出样例
PATestPATestPTetPTePePee
分析
感谢送分。
代码
#include<iostream>
#include<string>
using namespace std;
int main(){
int a[6] = {0};
string s;
cin>>s;
for(int i = 0;s[i];++i){
if(s[i] == 'P')++a[0];
if(s[i] == 'A')++a[1];
if(s[i] == 'T')++a[2];
if(s[i] == 'e')++a[3];
if(s[i] == 's')++a[4];
if(s[i] == 't')++a[5];
}
int N = a[0]+a[1]+a[2]+a[3]+a[4]+a[5];
for(int i = 1;i <= N;++i){
if(a[0] != 0){cout<<'P';--a[0];
}
if(a[1] != 0){cout<<'A';--a[1];
}
if(a[2] != 0){cout<<'T';--a[2];
}
if(a[3] != 0){cout<<'e';--a[3];
}
if(a[4] != 0){cout<<'s';--a[4];
}
if(a[5] != 0){cout<<'t';--a[5];
}
}
}