资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
n个人参加某项特殊考试。
为了公平,要求任何两个认识的人不能分在同一个考场。
求是少需要分几个考场才能满足条件。
输入格式
第一行,一个整数n(1<n<100),表示参加考试的人数。
第二行,一个整数m,表示接下来有m行数据
以下m行每行的格式为:两个整数a,b,用空格分开 (1<=a,b<=n) 表示第a个人与第b个人认识。
输出格式
一行一个整数,表示最少分几个考场。
样例输入
5
8
1 2
1 3
1 4
2 3
2 4
2 5
3 4
4 5
样例输出
4
样例输入
5
10
1 2
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
样例输出
5
#include<iostream>
#include<vector>
using namespace std;
int relation [101][101];
vector < vector <int> > room;
//int room [101][101];
int ans=101;
int n,m;
int dfs (int x,int sum)
{
if(x>n)
{
ans=min(sum,ans);
return 0;
}
if(sum>=ans)
return 0;
for(int i=1;i<=sum;i++)
{
int flag=0;
for(int j=0;j<room[i].size();j++)
if(relation[x][room[i][j]]==1)
{
flag++;
break;
}
if(flag==1) continue ;
else{
room[i].push_back(x);
dfs(x+1,sum);
room[i].pop_back();
}
}
room[sum+1].push_back(x);
dfs(x+1,sum+1);
room[sum+1].pop_back();
return 0;
}
int main()
{
cin>>n>>m;
room.resize(n+1);
for(int i=0;i<m;i++)
{
int a,b;
cin>>a>>b;
relation[a][b]=1;
relation[b][a]=1;
}
dfs(1,0);
cout<<ans;
}