hdu 1003 Max Sum

本文详细介绍了一种求解子序列最大和的算法实现,通过动态规划思想,该算法能够高效地找出给定整数序列中具有最大和的连续子序列,并返回其起始和结束位置。文章提供了完整的代码示例,解释了算法的工作原理和步骤,适用于初学者理解和掌握子序列最大和问题的解决方法。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:

14 1 4

 

Case 2:

7 1 6

#include<stdio.h>
int main()
{
    int T,i,j;
    scanf("%d",&T);
    for(i=1;i<=T;i++)
    {
        int n,f[100007],a,b,c,maxsum,sum;//a为maxsum的初始位置,b为maxsum的结束位置,c为序列的初始位置
        scanf("%d",&n);
        for(j=0;j<n;j++)
        {
            scanf("%d",&f[j]);
        }
        a=b=c=0;//初始化
        sum=maxsum=f[0];//初始化为第一个数
        if(sum<0)
        {
            sum=0;
            c=1;
        }
        for(j=1;j<n;j++)
        {
            sum+=f[j];
            if(sum>maxsum)//若当前的序列和大于最大值序列和时
            {
                maxsum=sum;
                a=c;//将a赋值为当前序列的初始位置
                b=j;
            }
            if(sum<0)//若序列和小于0时,开始新的序列
            {
                c=j+1;//更改新序列的初始位置
                sum=0;//重新初始化
            }
        }
        printf("Case %d:\n",i);
        printf("%d %d %d\n",maxsum,a+1,b+1);
        if(i!=T)
        {
            printf("\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值