杭电1001
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
#include<stdio.h>
main()
{
int n,i,sum; //定义:n为输入的数,sum是从一加到n的和。
while(scanf("%d",&n)!=EOF) //为满足题目要求,输入多组数据
{
sum=0;
for(i=1;i<=n;i++) //此循环目的是为了使i从1加到n
{sum=sum+i;}
printf("%d\n",sum);
printf("\n"); //注意题目要求上一个输出与下一个输出之间有一个空行
}
return 0;
}