chap 6 7-1 根据后序和中序遍历输出先序遍历 (25分)

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:

第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:

在一行中输出Preorder:以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

Preorder: 4 1 3 2 6 5 7

代码:

#include <iostream>
#include <stdio.h>
using namespace std;
int midle[31],tail[31];
typedef int TElemType;
typedef struct BiTNode
{
    TElemType data;
    struct BiTNode *lchild,*rchild;
}BiTNode,*BiTree;
BiTree Build(int *midle,int *tail,int n)//中序,后续,长度
{
    if(n<=0)
        return NULL;
    int *p=midle;
    while(p&&*p!=*(tail+n-1))//寻找根结点在中序的位置
    {
        p++;
    }
    BiTree T=new BiTNode;
    T->data = *p;
    int len = p - midle;
    T->lchild = Build(midle,tail,len);
	T->rchild = Build(p + 1,tail + len,n - len - 1);
	return T;
}

void Print(BiTree T){
	if(T)
    {
		printf(" %d",T->data);
		Print(T->lchild);
		Print(T->rchild);
	}
}
int main()
{
    int N,i;
    BiTree T;
    cin>>N;
    for(i=0;i<N;i++)
    {
        cin>>tail[i];
    }
    for(i=0;i<N;i++)
    {
        cin>>midle[i];
    }
    T=Build(midle,tail,N);
    cout<<"Preorder:";
    Print(T);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值