Silver Cow Party (Dijkstra 记个模板)

Silver Cow Party

 One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意

n个农场n个奶牛,x是开派对的地方,求每个奶牛到x的最短路的最大值。

第一时间想到把每个农场到x的最短路和x到他们自己农场的最短路都算一遍,结果肯定是超时了。

发现每个农场到x的最短路就是x到每个农场的最短路,但因为路是单向的,所以往回走的时候把所有路的双向的时间换一下,(即原本1->2=1 , 2->1=2 变为1->2=2, 2->1=1)再算一遍x到所有农场的最短路就好。

还有inf定的无穷大要大,不然就会wa = =!

#include <iostream>
#include <string.h>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include <map>
#include<set>
#include<cstdio>
#include<vector>
#include<list>
#include<time.h>
#include<bitset>
using namespace std;
int e[1005][1005];
int dis[1005];
int dis2[1005];
int book[1005];
int inf=9999999;
int n,m,x;
int main()
{
    scanf("%d %d %d",&n,&m,&x);
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            if(i==j)
                e[i][j]=0;
            else
                e[i][j]=inf;
        }
    }

    for(int i=0; i<m; i++)
    {
        int a,b,c;
        scanf("%d %d %d",&a,&b,&c);
        e[a][b]=c;
    }

    memset(book,0,sizeof(book));

    for(int i=1; i<=n; i++)
    {
        dis[i]=e[x][i];
    }
    book[x]=1;

    for(int i=0; i<n-1; i++)
    {
        int mi=inf;
        int u;
        for(int j=1; j<=n; j++)
        {
            if(!book[j]&&dis[j]<mi)
            {
                mi=dis[j];
                u=j;
            }
        }
        book[u]=1;
        for(int j=1; j<=n; j++)
        {
            if(e[u][j]<inf)
            {
                if(dis[j]>dis[u]+e[u][j])
                    dis[j]=dis[u]+e[u][j];
            }
        }
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<i;j++)
        {
            int mm=e[i][j];
            e[i][j]=e[j][i];
            e[j][i]=mm;
        }
    }

    memset(book,0,sizeof(book));
    for(int i=1; i<=n; i++)
    {
        dis2[i]=e[x][i];
    }
    book[x]=1;

    for(int i=0; i<n-1; i++)
    {
        int mi=inf;
        int u;
        for(int j=1; j<=n; j++)
        {
            if(!book[j]&&dis2[j]<mi)
            {
                mi=dis2[j];
                u=j;
            }
        }
        book[u]=1;
        for(int j=1; j<=n; j++)
        {
            if(e[u][j]<inf)
            {
                if(dis2[j]>dis2[u]+e[u][j])
                    dis2[j]=dis2[u]+e[u][j];
            }
        }
    }
    int ma=0;
    for(int i=1;i<=n;i++)
    {
        ma=max(ma,dis[i]+dis2[i]);
    }
    printf("%d\n",ma);
}

 

**描述:“适用于JDK8的环境”** 本文将深入探讨Neo4j社区版3.5.6版本,这是一个基于图数据库的强大工具,特别适用于知识图谱构建和可视化。由于其运行需求,必须在Java Development Kit(JDK)8的环境下进行安装和操作。 **一、Neo4j概述** Neo4j是一款开源的图形数据库,它以节点、关系和属性的形式存储数据,这使得处理复杂网络结构的数据变得更为直观和高效。Neo4j社区版是免费的,适合开发和学习用途,而企业版则提供了更多的高级功能和服务。 **二、JDK8要求** 为了运行Neo4j 3.5.6,你需要在你的计算机上安装JDK8。JDK是Java开发工具包,包含了运行Java应用程序所需的Java虚拟机(JVM)以及一系列开发工具。确保安装的是与Neo4j版本兼容的JDK版本至关重要,因为不兼容的JDK可能会导致运行错误或性能问题。 **三、安装和配置** 1. **下载与解压**: 从官方渠道下载"neo4j-community-3.5.6.zip"压缩文件,并将其解压到你选择的目录。 2. **环境变量配置**: 配置系统环境变量,将Neo4j的bin目录添加到PATH环境变量中,以便于命令行启动和管理数据库。 3. **修改配置文件**: Neo4j的配置主要通过`conf/neo4j.conf`文件进行,如需更改默认设置,如内存分配、端口设置等,应在此文件中进行修改。 4. **启动和停止**: 使用`neo4j console`命令启动服务,`neo4j stop`命令关闭服务。 **四、知识图谱与可视化** Neo4j因其强大的图数据模型,成为构建知识图谱的理想选择。你可以使用Cypher查询语言来操作和查询图数据,它的语法简洁且直观,易于学习。 1. **Cypher语言**: Cypher是一种声明式、图形化
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值