Consecutive Integers

探讨了从N个连续整数中选择K个连续整数的方法数量,提供了一个简洁的算法解决方案,通过减法原理快速计算可能的选择方式。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Consecutive Integers

Problem Statement

 

Snuke has N integers: 1,2,[ldots],N. He will choose K of them and give those to Takahashi.

How many ways are there to choose K consecutive integers?

Constraints

 

  • All values in input are integers.
  • 1≤KN≤50

Input

 

Input is given from Standard Input in the following format:

N K

Output

 

Print the answer.

Sample Input 1

 

3 2

Sample Output 1

 

2

There are two ways to choose two consecutive integers: (1,2) and (2,3).

Sample Input 2

 

13 3

Sample Output 2

 

11

在装编译器的时候都看见大家都过了这个题,然后看了看,想一会竟然没想明白,.......然后编译器装好了,看C,一下子就过了,然后回来看B,一下子就...发现这么...吗,就过了。

#include<bits/stdc++.h>

using namespace std;
int main()
{
	int n,k;
	while(cin >> n >> k){
		cout << n-(k-1) << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值