Consecutive Integers
Problem Statement
Snuke has N integers: 1,2,[ldots],N. He will choose K of them and give those to Takahashi.
How many ways are there to choose K consecutive integers?
Constraints
- All values in input are integers.
- 1≤K≤N≤50
Input
Input is given from Standard Input in the following format:
N K
Output
Print the answer.
Sample Input 1
3 2
Sample Output 1
2
There are two ways to choose two consecutive integers: (1,2) and (2,3).
Sample Input 2
13 3
Sample Output 2
11
在装编译器的时候都看见大家都过了这个题,然后看了看,想一会竟然没想明白,.......然后编译器装好了,看C,一下子就过了,然后回来看B,一下子就...发现这么...吗,就过了。
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n,k;
while(cin >> n >> k){
cout << n-(k-1) << endl;
}
return 0;
}