这是我做的第一个dfs题目
加油啊hhh
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3087 Accepted Submission(s): 1765
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or
@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@@
@@**@
0 0
Sample Output
0
1
2
2
题目大意就是**#**代表油田,我们去寻找与练成片的油田有多少个。斜对角的油田也算是连成一片。这样我们对八个方向进行搜索即可。
大体思路就是进行扫描每一个油田,然后,再对该油田的四周进行dfs,表示连在一起的油田,我们这里使用枚举,其实使用dir数组储存方向也可以,但是看起来不够直观。
.
// An highlighted block
#include <stdio.h>
char map[101][101];
int m,n;
//int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1}};
void dfs(int x,int y){
// int tx,ty;
// map[x][y]='*';
// for(int i=0;i<8;i++){
// tx=x+dir[i][0];
// ty=y+dir[i][1];
// if(tx<0||ty<0||tx>m||ty>n){
// continue;}
// if(map[tx][ty]=='@')
// dfs(tx,ty);
//}
if(map[x][y]!='@'||x<0||y<0||x>=m||y>=n)return;
else{
map[x][y]='*';
dfs(x-1,y-1);
dfs(x-1,y);
dfs(x-1,y+1);
dfs(x,y+1);
dfs(x,y-1);
dfs(x+1,y-1);
dfs(x+1,y);
dfs(x+1,y+1);
}
}
int main(){
while(1){
scanf("%d%d",&m,&n);
if(m==0){
break;
}
int sum=0;
for(int i=0;i<m;i++){
scanf("%s",map[i]);
}
for(int i=0;i<m;i++){
for(int j=0;j<n;j++){
if(map[i][j]=='@'){
dfs(i,j);
sum++;
}
}
}
printf("%d\n",sum);
}
return 0;
}