This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
#include <iostream>
#include <iomanip>
using namespace std;
const int maxn = 2001;
double ans[maxn] = {0};//存放结果 因为相乘后指数可能最大为2000,所以ans数组最大要开到2001
//当一个数组搞不定的时候 不要去死磕 就直接再开一个数组或者结构体数组就行
struct Poly{
double c;//系数
int e;//指数
}pol[1001]; //第一个多项式
int main(){
int k1, k2, e;
double c;
int count = 0;
cin >> k1;
for(int j = 0; j < k1; j++){ //记录第一个多项式的指数 与 系数
cin >> pol[j].e >> pol[j].c;
}
cin >> k2;
for(int i = 0; i < k2; i++){
cin >> e >> c; //输入第二个多项式的 指数 和 系数
for(int j = 0; j < k1; j++){ //第二个多项式的 指数和系数 直接与 第一个多项式相乘 累加到 对应指数的系数上去
ans[e + pol[j].e] += (c * pol[j].c);
}
}
for(int i=0; i<=2000; i++){
if(ans[i] != 0) count++; //累计非零项数的项数
}
cout << count;
for(int i=2000; i >= 0; i--){
if(ans[i] != 0){
cout << fixed << setprecision(1) << " " << i << " " << ans[i];
}
}
return 0;
}