Problem Description
Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus - Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.
We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit - he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.
We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.
Input
There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:
Vi [TAB] Ti
Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.
Output
Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.
Sample Input
4
20 0
25 -155
27 190
30 240
2
21 0
22 34
0
Sample Output
780
771
分析:本题是要算出Charley到达Yanyuan的时间,如果我们在x-y直角坐标系里把所有的直线y = Vi * ( x - Ti )画出来的话,可以发现Charley到达Yanyuan的时间就是所有的直线(Ti小于0的不算)与y = 4.5km交点的x坐标最小点的x坐标。由4.5 = Vi * ( x - Ti)转换得x = 4.5 / Vi * 60 * 60 + Ti,所以算出Ti大于等于零的所有x值,最小的便是到达时间,最后再用ceil向上取整即可。
#include<stdio.h>
#include<math.h>
const int maxn = 10005;
int v[maxn], t[maxn];
int main()
{
int n;
double mint, tt;
while (~scanf("%d", &n) && n) {
mint = 999999999;
for (int i = 0; i < n; ++i) {
scanf("%d%d", &v[i], &t[i]);
if (t[i] >= 0) {
tt = 4.5 / v[i] * 60 * 60 + t[i];
if (tt < mint) mint = tt;
}
}
printf("%.0lf\n", ceil(mint)); // ceil(x) 返回不小于x的最小整数值(返回值为浮点型)
}
return 0;
}