This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
#include<iostream>
#include<string>
#include<algorithm>
#include<math.h>
#include<queue>
#include<vector>
using namespace std;
int n;
int ele[10010];
vector<vector<int>> matrix;
bool cmp(int a, int b) {
return a > b;
}
int main() {
cin >> n;
for (int i = 0; i < n; i++) {
cin >> ele[i];
}
sort(ele, ele + n, cmp);
int r, c;
r = c = pow(n, 0.5);
while (r*c != n) {
r++;
}
matrix.resize(r);
for (int i = 0; i < r; i++) {
matrix[i].resize(c);
}
int i = 0, j = 0, k = 0, cnt = 0;
while (true) {
if (k >= n) break;
else{
for (i = cnt, j = cnt; j < c - cnt; j++) {
matrix[i][j] = ele[k++];
}
}
if (k >= n) break;
else {
j--;
for (++i; i < r - cnt; i++) {
matrix[i][j] = ele[k++];
}
}
if (k >= n) break;
else {
i--;
for (--j; j >= cnt; j--) {
matrix[i][j] = ele[k++];
}
}
cnt++;
if (k >= n) break;
else {
for (--i, ++j; i >= cnt; i--) {
matrix[i][j] = ele[k++];
}
i++;
}
}
for (i = 0; i < r; i++) {
for (j = 0; j < c; j++) {
if (j == 0) printf("%d", matrix[i][j]);
else printf(" %d", matrix[i][j]);
}
printf("\n");
}
return 0;
}