1105 Spiral Matrix (25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

#include<iostream>
#include<string>
#include<algorithm>
#include<math.h>
#include<queue>
#include<vector>
using namespace std;
int n;
int ele[10010];
vector<vector<int>> matrix;
bool cmp(int a, int b) {
	return a > b;
}
int main() {
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> ele[i];
	}
	sort(ele, ele + n, cmp);
	int r, c;
	r = c = pow(n, 0.5);
	while (r*c != n) {
		r++;
	}
	matrix.resize(r);
	for (int i = 0; i < r; i++) {
		matrix[i].resize(c);
	}
	int i = 0, j = 0, k = 0, cnt = 0;
	while (true) {
		if (k >= n) break;
		else{
			for (i = cnt, j = cnt; j < c - cnt; j++) {
				matrix[i][j] = ele[k++];
			}
		}
		if (k >= n) break;
		else {
			j--;
			for (++i; i < r - cnt; i++) {
				matrix[i][j] = ele[k++];
			}
		}
		if (k >= n) break;
		else {
			i--;
			for (--j; j >= cnt; j--) {
				matrix[i][j] = ele[k++];
			}
		}
		cnt++;
		if (k >= n) break;
		else {
			for (--i, ++j; i >= cnt; i--) {
				matrix[i][j] = ele[k++];
			}
			i++;
		}
	}
	for (i = 0; i < r; i++) {
		for (j = 0; j < c; j++) {
			if (j == 0) printf("%d", matrix[i][j]);
			else printf(" %d", matrix[i][j]);
		}
		printf("\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值