Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given Lbeing 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address
is the position of the node, Data
is an integer, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
作者: 陈越
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB
我的代码在DEV上运行良好,但不知为何,提交上去会显示运行错误,请大神指点。
#include<stdio.h>
#include<string.h>
struct Node
{
char address[5];
int data;
char next[5];
};
typedef Node node;
int main()
{
node n[100000];
char firstaddr[5];
int N,K;
scanf("%s %d %d",firstaddr,&N,&K);
node t;
for(int i=0;i<N;i++)
{
scanf("%s %d %s",n[i].address,&n[i].data,n[i].next);
if(strcmp(n[i].address,firstaddr)==0)
{
t=n[i];
n[i]=n[0];
n[0]=t;
}
}
for(int i=0;i<N;i++)
{
for(int j=i+1;j<N;j++)
{
if(strcmp(n[i].next,n[j].address)==0)
{
t=n[j];
n[j]=n[i+1];
n[i+1]=t;
break;
}
}
}
int i=K-1,j=0,tt=0;
while(i<N)
{
while((i-tt)>(j+tt))
{
t=n[i-tt];
n[i-tt]=n[j+tt];
n[j+tt]=t;
tt++;
}
tt=0;
j=j+K;
i=i+K;
}
for(int m=0;m<N-1;m++)
{
if(strcmp(n[m].next,"-1")==0)strcpy(n[N-1].next,n[m].next);
strcpy(n[m].next,n[m+1].address);
}
for(int i=0;i<N;i++)
{
printf("%s %d %s\n",n[i].address,n[i].data,n[i].next);
}
}
查看别人的代码如下:
#include<iostream>
#include<stdio.h>
#include<algorithm> ///使用到reverse 翻转函数
using namespace std;
#define MAXSIZE 1000010 ///最大为五位数的地址
struct node ///使用顺序表存储data和下一地址next
{
int data;
int next;
}node[MAXSIZE];
int List[MAXSIZE]; ///存储可以连接上的顺序表
int main()
{
int First, n, k;
cin>>First>>n>>k; ///输入头地址 和 n,k;
int Address,Data,Next;
for(int i=0;i<n;i++)
{
cin>>Address>>Data>>Next;
node[Address].data=Data;
node[Address].next=Next;
}
int j=0; ///j用来存储能够首尾相连的节点数
int p=First; ///p指示当前结点
while(p!=-1)
{
List[j++]=p;
p=node[p].next;
}
int i=0;
while(i+k<=j) ///每k个节点做一次翻转
{
reverse(&List[i],&List[i+k]);
i=i+k;
}
for(i=0;i<j-1;i++)
printf("%05d %d %05d\n",List[i],node[List[i]].data,List[i+1]);
printf("%05d %d -1\n",List[i],node[List[i]].data);
return 0;
}
---------------------
版权声明:本文为优快云博主「Kunaly」的原创文章,遵循CC 4.0 by-sa版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.youkuaiyun.com/qq_33406883/article/details/52793520
该代码使用了reverse反转函数,数据结构也与我设计的不同,结构体中存的是当前的数据和下一个指向的地址,下标为当前地址。