02-线性结构3 Reversing Linked List (25 分)

这篇博客介绍了一种处理链表问题的方法,即如何根据给定的步长K逆向链表中的每K个元素。作者给出了具体的操作过程,并提供了一个示例代码,该代码利用C++中的`reverse`函数实现链表的翻转。代码中,链表节点存储数据和下一个节点的位置,并用顺序表辅助操作。虽然代码在本地环境运行正常,但在提交时遇到了运行错误,作者寻求帮助并分享了其他人的解决方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given Lbeing 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

作者: 陈越

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

 

我的代码在DEV上运行良好,但不知为何,提交上去会显示运行错误,请大神指点。

#include<stdio.h>
#include<string.h>
struct Node
{
	char address[5];
	int data;
	char next[5];
};
typedef Node node;

int main()
{
	node n[100000];
	char firstaddr[5];
	int N,K;
	scanf("%s %d %d",firstaddr,&N,&K);
	node t;
	for(int i=0;i<N;i++)
	{
		scanf("%s %d %s",n[i].address,&n[i].data,n[i].next);
		if(strcmp(n[i].address,firstaddr)==0)
		{
			
			t=n[i];
			n[i]=n[0];
			n[0]=t;
		}
	}

	for(int i=0;i<N;i++)
	{
		for(int j=i+1;j<N;j++)
		{
			if(strcmp(n[i].next,n[j].address)==0)
			{
				t=n[j];
				n[j]=n[i+1];
				n[i+1]=t;
				break;
			}
		}
	}


	int i=K-1,j=0,tt=0;
	while(i<N)
	{
		while((i-tt)>(j+tt))
		{
			t=n[i-tt];
			n[i-tt]=n[j+tt];
			n[j+tt]=t;
			tt++;
		}
		tt=0;
		j=j+K;
		i=i+K;
	}
	for(int m=0;m<N-1;m++)
	{
		if(strcmp(n[m].next,"-1")==0)strcpy(n[N-1].next,n[m].next);
		strcpy(n[m].next,n[m+1].address);
	}
	for(int i=0;i<N;i++)
	{
		printf("%s %d %s\n",n[i].address,n[i].data,n[i].next);
	}
}

查看别人的代码如下:

#include<iostream>
#include<stdio.h>
#include<algorithm>    ///使用到reverse 翻转函数
using namespace std;
 
#define MAXSIZE 1000010   ///最大为五位数的地址
 
struct node    ///使用顺序表存储data和下一地址next
{
   int data;   
   int next;
}node[MAXSIZE];
 
int List[MAXSIZE];   ///存储可以连接上的顺序表
int main()
{
    int First, n, k;  
    cin>>First>>n>>k;   ///输入头地址 和 n,k;
    int Address,Data,Next;
    for(int i=0;i<n;i++)
    {
        cin>>Address>>Data>>Next;
        node[Address].data=Data;
        node[Address].next=Next;
    }
 
    int j=0;  ///j用来存储能够首尾相连的节点数
    int p=First;   ///p指示当前结点
    while(p!=-1)
    {
        List[j++]=p;
        p=node[p].next;
    }
    int i=0;
    while(i+k<=j)   ///每k个节点做一次翻转
    {
        reverse(&List[i],&List[i+k]);
        i=i+k;
    }
    for(i=0;i<j-1;i++)
        printf("%05d %d %05d\n",List[i],node[List[i]].data,List[i+1]);
    printf("%05d %d -1\n",List[i],node[List[i]].data);
    return 0;
}
--------------------- 
版权声明:本文为优快云博主「Kunaly」的原创文章,遵循CC 4.0 by-sa版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.youkuaiyun.com/qq_33406883/article/details/52793520

该代码使用了reverse反转函数,数据结构也与我设计的不同,结构体中存的是当前的数据和下一个指向的地址,下标为当前地址。

题目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。题目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 题目析 本题需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值