A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
思路:二叉搜索树中序,元素从小到大排列。
1.中序一次记录中序序列的数组下标,对排序后的a数组填入res数组中。2.然后层序遍历一次记录层序遍历的数组下标。按数组下标输出相应元素。
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
struct node {
int l, r, pos;
}s[110];
vector<int > v,lay;
void inorder(int index) {
if (s[index].l != -1)
inorder(s[index].l);
v.push_back(s[index].pos);
if (s[index].r != -1)
inorder(s[index].r);
}
void layer(int index) {
queue<int > q;
q.push(index);
while (!q.empty()) {
int temp = q.front();
q.pop();
lay.push_back(temp);
if (s[temp].l != -1)
q.push(s[temp].l);
if (s[temp].r != -1)
q.push(s[temp].r);
}
}
int main(){
int n, a[110], res[110];
cin >> n;
for (int i = 0; i < n; i++) {
cin >> s[i].l >> s[i].r;
s[i].pos = i;
}
for (int i = 0; i < n; i++) {
cin >> a[i];
}
sort(a, a + n);
inorder(0);
for (int i = 0; i < v.size(); i++) {
res[v[i]] = a[i];
}
layer(0);
for (int i = 0; i < n; i++) {
if (i != 0)
cout << " ";
cout << res[lay[i]];
}
}