C++——Aggressive cows

描述
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
输入

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    输出

  • Line 1: One integer: the largest minimum distance
    样例输入
    5 3
    1
    2
    8
    4
    9
    样例输出
    3
    提示
    OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
来源
USACO 2005 February Gold

#include<stdio.h>
#include<stdlib.h>
int n,c;
int *a;
int cmp(const void* b,const void* c)
{
    return *(int*)b-*(int*)c;
}
int f(int x)
{
    int cnt = 1;
    int cur = a[0];//因为a[0]是最小的,所以直接确定。
    int i;
    for(i=1;i<n;i++)
    {
        if(a[i]-cur>=x)
        {
            cnt++;
            cur = a[i];
            if(cnt>=c)
                return 1;
        }
    }
    return 0;
}
int main()
{
    int i;
    int l,r,mid;
    while(scanf("%d%d",&n,&c)!=EOF)
    {
        a = (int*)malloc(sizeof(int)*n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        qsort(a,n,sizeof(int),cmp);
        l=0;
        r=a[n-1]-a[0];
        while(l<=r)
        {
            mid=(l+r)/2;
            if(f(mid))
                l=mid+1;//增大,继续试探,注意输出结果要减一,因为在这多加了
            else
                r=mid-1;//所求处理小于mid
        }
        printf("%d\n",l-1);
    }
    return 0;
}
### VAD Implementation in C++ Library or Code Example For implementing Voice Activity Detection (VAD) using C++, several libraries and approaches are available that provide robust solutions. One notable approach involves leveraging existing well-established libraries designed specifically for audio processing tasks. WebRTC is an open-source project offering a comprehensive set of communication tools including VAD functionality written in C++. This library provides high-quality real-time communications capabilities over the Internet, encompassing voice calling features such as noise suppression, echo cancellation, and indeed VAD[^1]. A simple usage example with WebRTC's VAD module might look like this: ```cpp #include "webrtc/modules/audio_processing/include/audio_processing.h" #include "webrtc/modules/audio_processing/vad/webrtc_vad.h" int main() { webrtc::VoiceActivityDetector vad; // Initialize VAD settings. VadInstance* handle = WebRtc_Vad_Create(); int err = WebRtc_Vad_Init(handle); // Set mode where 0=aggressive, 1=low bit-rate, 2=normal, 3=very aggressive. err += WebRtc_Vad_set_mode(handle, 2); // Assuming 'audio_frame' contains your PCM data... bool active_speech = false; size_t samples_per_channel = /* number_of_samples */; const uint8_t likelihood = WebRtc_Vad_Process(handle, /* sample_rate_hz */ 16000, reinterpret_cast<const int16_t*>(audio_frame), samples_per_channel); if(likelihood >= 75){ active_speech = true; } } ``` Another option includes exploring third-party libraries compatible with platforms similar to standard Linux systems which could also support OpenHarmony projects after appropriate adaptation efforts have been made according to their documentation guidelines provided elsewhere[^3].
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值