迷宫问题 POJ - 3984

本文介绍了一种解决迷宫最短路径问题的算法,通过使用广度优先搜索(BFS)策略,从迷宫的起点出发,寻找到达终点的最短路径。文章详细展示了如何定义迷宫的二维数组表示,以及如何实现BFS算法来遍历迷宫并记录路径。此外,还提供了一个C++代码示例,用于演示如何应用该算法。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

AC代码(个人觉得记录路径是一个难点)

Select Code

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
//#include <bits/stdc++.h>
using namespace std;
int mp[10][10];
int vis[10][10];
int n = 5;
struct node
{
    int x, y;
    int c;
}s, t, q[100];
int nxt[5][3] = {{0,1},{0,-1},{1,0},{-1,0}};
void yin(int head) //先走到最后然后再通过递归来输出路线
{
    while(q[head].c!=-1)
    {
        yin(q[head].c);
        printf("(%d, %d)\n",q[head].x, q[head].y);
        return;
    }
   printf("(%d, %d)\n",0,0);
}
void bfs(int ii, int jj)
{
    int i;
    memset(vis, 0, sizeof(vis));
    int tail = 0, head = 0;
    s.x = ii, s.y = jj, s.c = -1;
    q[tail++] = s;
    vis[s.x][s.y] = 1;
    while(head<tail)
    {
        s = q[head];
        if(s.x==4&&s.y==4)
        {
            yin(head);
            return;
        }
        for(i = 0;i<4;i++)
        {
            t.x = s.x+nxt[i][0];
            t.y = s.y+nxt[i][1];
            if(t.x>=0&&t.x<n&&t.y>=0&&t.y<n&&mp[t.x][t.y]!=1&&!vis[t.x][t.y])
            {
                vis[t.x][t.y] = 1;
                t.c = head; //记录上一个走过的点
                q[tail++] = t;
            }
        }
        head++;
    }
    return;
}
int main()
{
    int i, j;
    for(i = 0;i<n;i++)
    {
        for(j = 0;j<n;j++)
        {
            scanf("%d",&mp[i][j]);
        }
    }
    bfs(0,0);
    return 0;
}
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路数组记录路。最后,使用栈来输出路
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值