pat a1001

本文详细解析了1001A+BFormat题目,介绍了如何计算两个整数的和并以标准格式输出,即用逗号分隔每三位数字。文章包括输入规格、输出规格及示例,适合初学者理解和实践。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9
Sample Output:

-999,991

代码
#include<stdio.h>
int main()
{
int a,b;
int sum;
int t=0;
int i=0;
int c[7];
scanf("%d%d",&a,&b);
sum=a+b;
if(sum<0)
{
printf("-");
sum=-sum;
}
if(sum0)
printf(“0”);
while(sum)
{
c[i]=sum%10;
sum=sum/10;
i++;
}
if(i%3!=0)
{
for(int j=i-1;j>i-1-i%3;j–)
printf("%d",c[j]);
if(i>3)
printf(",");
for(int k=i-1-i%3;k>=0;k–)
{
printf("%d",c[k]);
t++;
if(t%3
0&&k!=0)
{
printf(",");
t=0;
}
}
}
else
for(int j=i-1;j>=0;j–)
{
printf("%d",c[j]);
t++;
if(t%3==0&&j!=0)
{
printf(",");

   }
}

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值