Problem Description In computer science, a character is a letter, a digit, a punctuation mark or some other similar symbol. Since computers can only process numbers, number codes are used to represent characters, which is known as character encoding. A character encoding system establishes a bijection between the elements of an alphabet of a certain size n and integers from 0 to n−1 . Some well known character encoding systems include American Standard Code for Information Interchange (ASCII), which has an alphabet size 128, and the extended ASCII, which has an alphabet size 256.
Input The first line of input is a single integer T (1≤T≤400) , the number of test cases.
Output For each test case, display the answer modulo 998244353 in a single line.
Sample Input 4 2 3 3 2 3 4 3 3 3 128 3 340
Sample Output 1 0 7 903
Source |
神一样的题目,神一样的大佬
这里讲的比较好: https://blog.youkuaiyun.com/gymgym1212/article/details/81708498
逆元运算:https://blog.youkuaiyun.com/qq_41431457/article/details/89813606
#include<bits/stdc++.h>
#define lom long long
#define M 200005
const int mod=998244353;
using namespace std;
lom inv[M],A[M];
lom quick(lom a,lom b,lom c)//快速幂取模
{
lom ans=1;
a%=c;
while(b)
{
if(b&1) ans=ans*a%c;
a=a*a%c;
b>>=1;
}
return ans%c;
}
void getinv()
{
inv[0]=quick(1,mod-2,mod);
A[0]=1;
for(int i=1;i<=M;i++)
{
A[i]=A[i-1]*i%mod;//i!
inv[i]=quick(A[i],mod-2,mod);//i! 的逆元
}
}
lom C(lom a,lom b)
{
if(b>a) return 0;
return A[a]*inv[b]%mod*inv[a-b]%mod;
}
int main()
{
getinv();
int t;
cin>>t;
while(t--)
{
lom n,m,k;
cin>>n>>m>>k;
if(k==0)
cout<<'1'<<endl;
else if(k>m*(n-1))
cout<<'0'<<endl;
else if(k<n)
cout<<C(m+k-1,k)<<endl;
else
{
lom ans=C(m+k-1,m-1);
int flag=-1;
for(int i=1; i<=m; i++)
{
ans+=flag*C(m,i)*C(m+k-i*n-1,m-1)%mod;
ans=(ans%mod+mod)%mod;
flag=-1*flag;
}
cout<<ans<<endl;
}
}
return 0;
}