【题解】POJ 1852 Ants

探讨了在长为Lcm的竹竿上,N只不明方向的蚂蚁以1cm/s速度爬行,求所有蚂蚁掉落竹竿的最短时间和最长时间。通过分析蚂蚁相遇的抽象模型,得出解决方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

目录

 

题目描述

题意分析

AC代码


题目描述

 

Time limit                                         Memory limit

1000 ms                                             30000 kB

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

题意分析

题意:   长为 Lcm 的竹竿上有N只不明方向的小蚂蚁。其以1cm/s的速度爬行,若两只蚂蚁遭遇。

              则调转,问全部蚂蚁掉落竹竿的  最短时间 和 最长时间 分别是多少?

 

              关于最短时间,我们仅需要比较 每只蚂蚁到竹竿两端的距离的最小值,取所有蚂蚁的最大值即可

              关于最长时间,则为两端的距离的最大值,取所有蚂蚁的最大值。

              这是由于两只蚂蚁相遇,我们可以抽象的看为数轴上的两点对穿而过。那么我们取每只蚂蚁最符合题意的状态

              便可得到此结果。

 

AC代码

#include <cstdio>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int main()
{
    int t,L,n;
    cin>>t;
    while(t--)
    {
        int maxone = 0,minone = 0;
        int p;
        scanf("%d%d",&L,&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&p);
            minone = max( minone , min(p,L-p) );
            maxone = max( maxone , max(p,L-p) );
        }
        printf("%d %d\n",minone,maxone);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值