题目描述
1081 Rational Sum (20分)
Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 …
where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
求解思路
用一个结构体关联分数的分子和分母,进行分数的相加与化简运算即可。
代码实现(AC)
#include<cstdio>
#include<cmath>
struct Fraction{
long long up,down;
};
int gcd(int a,int b)
{
return !b?a:gcd(b,a%b);
}
/*分数化简*/
Fraction reduction(Fraction result)
{
if(result.down<0) //分母为负数,令分子和分母都变为相反数
{
result.up=(-result.up);
result.down=(-result.down);
}
if(result.up==0) //如果分子为0,则令分母为1
{
result.down=1;
}
else //如果分子不为零,则进行约分,约去最大公约数
{
int d=gcd(abs(result.up),abs(result.down));
result.up/=d;
result.down/=d;
}
return result;
}
Fraction add(Fraction f1,Fraction f2)
{
Fraction result;
result.up=f1.up*f2.down+f1.down*f2.up;
result.down=f1.down*f2.down;
return reduction(result); //结果注意化简
}
void showResult(Fraction r)
{
reduction(r);
if(r.down==1) printf("%lld\n",r.up); //整数
else if(abs(r.up)>r.down)
{
printf("%lld %lld/%lld\n",r.up/r.down,abs(r.up)%r.down,r.down); //假分数
}
else
{
printf("%lld/%lld",r.up,r.down); //真分数
}
}
int main()
{
int n;
scanf("%d",&n);
Fraction sum,temp;
sum.up=0;
sum.down=1;
for(int i=0;i<n;i++)
{
scanf("%lld/%lld\n",&temp.up,&temp.down);
sum=add(sum,temp);
}
showResult(sum);
return 0;
}