题目描述
1061 Dating (20分)
Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm.
It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week –
that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04
求解思路
- 题意:给定字符串s1,s2,s3,s4;s1[i]==s2[i]且s1[i]为A~G之间的大写字符,该字符对应了星期数,从该位置往后遇到的第二个s1[i]==s2[i],如果s1[i]为0-9之间的任何数字,则直接输出,如果为A-N之间的字符则转换为10-23;如果s3[i]=s4[i]则输出i作为分。
代码实现(AC)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
string s1,s2,s3,s4;
void solve()
{
cin>>s1>>s2>>s3>>s4;
string s[7]={"MON","TUE","WED","THU","FRI","SAT","SUN"};
int i=0;
for(i=0;i<s1.size()&&i<s2.size();i++)
{
if(s1[i]==s2[i]&&s1[i]>='A'&&s1[i]<='G')
{
cout<<s[s1[i]-'A']<<" ";
break;
}
}
i+=1;
for(;i<=s1.size()&&i<=s2.size();i++)
{
if(s1[i]==s2[i])
{
if(s1[i]>='0'&&s1[i]<='9')
{
printf("%02d:",s1[i]-'0');
break;
}
else if(s1[i]>='A'&&s1[i]<='N')
{
printf("%02d:",s1[i]-'A'+10);
break;
}
}
}
for(i=0;i<s3.size()&&i<s4.size();i++)
{
if(s3[i]==s4[i])
{
if((s3[i]>='A'&&s3[i]<='Z')||(s3[i]>='a'&&s3[i]<='z'))
{
printf("%02d",i);
break;
}
}
}
}
int main()
{
solve();
return 0;
}