题目
1043 Is It a Binary Search Tree (25分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node’s key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
- Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line YES
if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO
if not. Then if the answer is YES
, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
题目大意
二叉搜索树,左结点的值小于父节点的值,右结点的值大于等于父结点的值;
给出一个树的先序遍历序列,判断是否是一个二叉搜索树或其镜像的先序遍历序列;
是则输出YES,换行输出该树的后续遍历序列,不是则输出NO
思路
不是镜像的情况下,对于一个二叉搜索树的先序遍历序列,根据其自身的性质,可以找到左右子树的范围,当前根结点下标为root,第一个大于等于根结点的值的元素所在下标
i
i
i为右子树开始的结点,往前直到根结点为左子树的范围,记
j
j
j为从右边界开始第一个值小于根结点值的结点下标;
如何判断是否是二叉搜索树,如果是二叉搜索树, 则
i
−
j
=
1
i-j = 1
i−j=1 ,因为先序遍历序列右子树第一个结点是在左子树最后一个结点之后出现;不等于1则返回
根据递归得到的后序遍历序列的数组元素的个数是否等于树的结点个数来判断是否是二叉搜索树,因为可能是镜像所以最多需要进行两次的递归操作;当假设是镜像的情况下,
i
、
j
i、j
i、j的判断条件相反,因为左右子树是对换了的
代码
#include<bits/stdc++.h>
using namespace std;
vector<int> pre, post;
bool ifMirror = false, flag = false;
void judge(int left, int right){
if(left > right) return;
int i=left+1, j=right;
if(ifMirror == false){
while(i<=right && pre[i] < pre[left]) i++;
while(j>left && pre[j] >= pre[left]) j--;
}else{
while(i<=right && pre[i] >= pre[left]) i++;
while(j>left && pre[j] < pre[left]) j--;
}
if(i - j != 1) return;
judge(left+1, j);
judge(i, right);
post.push_back(pre[left]);
}
int main(int argc, const char * argv[]) {
int N;
cin>>N;
pre.resize(N);
for(int i=0;i<N; i++)
cin>>pre[i];
judge(0, N-1);
if(post.size() != N){
ifMirror = true;
post.clear();
judge(0, N-1);
if(post.size() != N){
printf("NO\n");
return 0;
}
}
printf("YES\n");
for(int i=0; i<N; i++){
printf("%s%d", i==0 ? "" : " ", post[i]);
}
return 0;
}