PAT 甲级 1040 Longest Symmetric String (25分)

题目

1040 Longest Symmetric String (25分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

题目大意

给出一个字符串,输出最长回文子串的长度

思路

每次从当前位置为中心,注意偶数长度和奇数长度的回文串的比较方式即可

代码

#include <bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    string s;
    getline(cin, s);
    int n = s.size(), maxlen = 0;
    for(int i=0; i<n; i++){
        int lens = 0;
        for(; i+lens<n && i+lens>=0 && s[i+lens] == s[i-lens]; lens++);
        maxlen = max(maxlen, 2*lens-1);
        lens = 0;
        for(; i-lens >=0 && i+lens+1<n && s[i-lens] == s[i+1+lens]; lens++);
        maxlen = max(maxlen, 2*lens);
    }
    cout<<maxlen;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值