PAT 甲级 1037 Magic Coupon (25分)

本文介绍了一种在火星魔法商店利用魔法券获取最大价值的算法。通过分析不同类型的魔法券和产品价值,采用排序和双指针技术,实现了最优配对,以最大化返现金额。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目

1037 Magic Coupon (25分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N C N_C NC, followed by a line with N C N_C NC coupon integers. Then the next line contains the number of products N P N_P NP, followed by a line with N P N_P NP product values. Here 1≤ N C N_C NC, N P N_P NP≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目大意

coupon:给出N个数字,拿一件商品,获得对应数字倍数的价值;
bonus:再给出M个数字,拿一件商品,付出对应数字倍数的价值;

思路

用coupon中最大的正数乘以bonus中最小的负数能够获得最大收益;
故对两个数组进行排序,使用双指针分别指向coupon和bonus中的元素,两者都小于0或者大于0时将其乘积加入结果变量;

代码

#include<bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int N, M;
    long long sum = 0;
    cin>>N;
    vector<long long> coupon(N), bonus;
    for(int i=0; i<N; i++)
        cin>>coupon[i];
    cin>>M;
    bonus.resize(M);
    for(int i=0; i<M; i++)
        cin>>bonus[i];
    sort(coupon.begin(), coupon.end());
    sort(bonus.begin(), bonus.end());
    int i = 0, j = 0;
    while(i<N && j<M && coupon[i] < 0 && bonus[j] < 0){
        sum += coupon[i] * bonus[j];
        i++;
        j++;
    }
    i = N-1;
    j = M-1;
    while(i>=0 && j>=0 && coupon[i] > 0 && bonus[j] > 0){
        sum += coupon[i] * bonus[j];
        i--;
        j--;
    }
    cout<<sum<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值