"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.
Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:3 11111 22222 33333 44444 55555 66666 7 55555 44444 10000 88888 22222 11111 23333Sample Output:
5
10000 23333 44444 55555 88888
没有用stl容器。。。最简单又最烦的做法了
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n;
int a[100010]={0};//a放名单
int b[100010]={0};//b统计是否来了
int c[100010];//c放来的人员
int d[100010];//d放输出结果
scanf("%d",&n);
int i,x,y;
for(i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
a[x]=y;
a[y]=x; //输入
}
int m;
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d",&c[i]);
b[c[i]]=1;//存进去
}
int j=0;
for(i=0;i<m;i++)
{
if(b[c[i]]!=0&&b[a[c[i]]]==0)//是否为单身狗
{
d[j]=c[i];
j++;
}
}
printf("%d\n",j);
sort(d,d+j);
for(i=0;i<j-1;i++)
printf("%d ",d[i]);
printf("%d\n",d[j-1]);
}