PAT :1121. Damn Single (25) 第二个测试点过不去 希望能有知道的大佬指点

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5

10000 23333 44444 55555 88888

没有用stl容器。。。最简单又最烦的做法了

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n;
	int a[100010]={0};//a放名单 
	int b[100010]={0};//b统计是否来了 
	int c[100010];//c放来的人员 
	int d[100010];//d放输出结果 
	scanf("%d",&n);
	int i,x,y;
	for(i=0;i<n;i++)
	{
		scanf("%d%d",&x,&y);
		a[x]=y;
		a[y]=x; //输入 
	}
	int m;
	scanf("%d",&m);
	for(i=0;i<m;i++)
	{
		scanf("%d",&c[i]);
		b[c[i]]=1;//存进去 
	}
	int j=0;
	for(i=0;i<m;i++)
	{
		if(b[c[i]]!=0&&b[a[c[i]]]==0)//是否为单身狗 
		{
			d[j]=c[i];
			j++;
		}
	}
	printf("%d\n",j);
	sort(d,d+j);
	for(i=0;i<j-1;i++)
	printf("%d ",d[i]);
	printf("%d\n",d[j-1]);
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值