Can you find it?

本文介绍了一道经典的三数求和算法题,通过预处理和二分查找的方法优化了时间复杂度,实现了高效求解。文章详细展示了算法思路及实现代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 37626    Accepted Submission(s): 9190


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
 
 
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
 
 
Case 1: NO YES NO
 

Author
wangye
 

Source
 
PS:将两个数组两两相加,再与另一数组相加,其中,与另一数组的计算过程中,用二分不断缩小区间,达到减小时间复杂度的目的。、

代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<map>
typedef long long ll;
using namespace std;
const int N=1e6+10;
int main()
{
    int l,n,m,kk=1;
    int a[550],b[550],c[550],d[260000];
    while(cin>>l>>n>>m)
    {
        int k=0;
        for(int i=0; i<l; i++)
            cin>>a[i];
        for(int i=0; i<n; i++)
            cin>>b[i];
        for(int i=0; i<m; i++)
            cin>>c[i];
        for(int i=0; i<l; i++)
            for(int j=0; j<n; j++)
                d[k++]=a[i]+b[j];
        sort(d,d+k);
        int s,x;
        cin>>s;
        cout<<"Case "<<kk++<<":"<<endl;
        while(s--)
        {
        int o=0;
            cin>>x;
            for(int i=0; i<m; i++)
            {
                if(binary_search(d,d+k,x-c[i]))
                {
                    o=1;
                    break;
                }
            }
            if(o)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值