Dungeon Master bfs

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
 
3维迷宫问题。每次可以向上,向下,向左,向右,向前,向后走。从起始点走到终点,求最小步数。我们可以用bfs,每次将六种情况压入队列(只要此位置能走而且没有走过)。没有什么很特殊的情况,直接暴力搜索就行。数组我们可以多开一点,把边界以外的都设为岩石(不能走),这样因为走不出去我们就可以不用判断边界的情况了。
 
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int a[34][34][34];                //用来表示迷宫。其中-1表示岩石,0表示可以走(输入字符的时候装换一下就行了)
bool b[34][34][34];               //用来判断是否走过此位置
int n,m,S;
struct f {
	int x,y,z,s;              //s表示步数
};
f start,end;                      //起点和终点
void bfs() {
	queue<f> q;
	q.push(start);
	f p,c;
	memset(b,0,sizeof(b));
	while(!q.empty()) {
		p=q.front() ;
		q.pop();
		if(p.x==end.x&&p.y==end.y&&p.z==end.z) {        //到达终点,更新终点的步数  
			end.s=p.s;
			return ;
		}
		if(a[p.x+1][p.y][p.z]==0&&b[p.x+1][p.y][p.z]==0) {
			c.x=p.x+1;
			c.y=p.y;
			c.z=p.z;
			c.s=p.s+1;
			q.push(c);
			b[p.x+1][p.y][p.z]=1;
		}
		if(a[p.x-1][p.y][p.z]==0&&b[p.x-1][p.y][p.z]==0) {
			c.x=p.x-1;
			c.y=p.y;
			c.z=p.z;
			c.s=p.s+1;
			q.push(c);
			b[p.x-1][p.y][p.z]=1;
		}
		if(a[p.x][p.y+1][p.z]==0&&b[p.x][p.y+1][p.z]==0) {
			c.x=p.x;
			c.y=p.y+1;
			c.z=p.z;
			c.s=p.s+1;
			q.push(c);
			b[p.x][p.y+1][p.z]=1;
		}
		if(a[p.x][p.y-1][p.z]==0&&b[p.x][p.y-1][p.z]==0) {
			c.x=p.x;
			c.y=p.y-1;
			c.z=p.z;
			c.s=p.s+1;
			q.push(c);
			b[p.x][p.y-1][p.z]=1;
		}
		if(a[p.x][p.y][p.z+1]==0&&b[p.x][p.y][p.z+1]==0) {
			c.x=p.x;
			c.y=p.y;
			c.z=p.z+1;
			c.s=p.s+1;
			q.push(c);
			b[p.x][p.y][p.z+1]=1;
		}
		if(a[p.x][p.y][p.z-1]==0&&b[p.x][p.y][p.z-1]==0) {
			c.x=p.x;
			c.y=p.y;
			c.z=p.z-1;
			c.s=p.s+1;
			q.push(c);
			b[p.x][p.y][p.z-1]=1;
		}

	}

}
int main() {
	int L,R,C;
	while(cin>>L>>R>>C) {
		if(L==0&&R==0&&C==0)
			break;
		char t;
		memset(a,-1,sizeof(a));                //先全部设为岩石,输入.时我们在变为可以走
      		for(int i=1; i<=L; i++) {             //从1开始,边界0为岩石,这样我们就不用判断边界了
			for(int j=1; j<=R; j++) {
				for(int k=1; k<=C; k++) {
					cin>>t;
					if(t=='S') {
						start.x=i;
						start.y=j;
						start.z=k;
						start.s=0;
					} else if(t=='.')
						a[i][j][k]=0;
					else if(t=='E') {
						end.x=i;
						end.y=j;
						end.z=k;
						a[i][j][k]=0;
					}
				}
			}
		}
		end.s=0;
		bfs();
		if(end.s!=0)
		cout<<"Escaped in "<<end.s<<" minute(s)."<<endl;
		else
		cout<<"Trapped!"<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值