1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题意:有n个客户,k个窗口。已知每个客户的到达时间和需要的时长,如果有窗口就依次过去,如果没有窗口就在黄线外等候(黄线外只有一个队伍,先来先服务),求客户的平均等待时长。银行开放时间为8点到17点,再8点之前不开门,8点之前来的人都要等待,在17点后来的人不被服务。

分析:

  1. 客户结构体node,里面有come为到达时间和time为需要服务的时长。
  2. 所有满足条件的(到来时间点在17点之前的)客户放入数组中,数组的长度就是需要服务的客户的个数
  3. windows数组表示某个窗口的结束时间
  4. 每一个客户到来的时候,选择最早结束时间的窗口. 如果最早结束时间比他还,那么他一来就能被服务,更新windows的值;如果最早结束时间比他,他需要等待,累加等待的时间,然后更新window的值。

具体实现:

  • 初始化:一开始所有窗口的值都为8点整(0-61200)。
  • 对所有客户要先进行排序,先来先服务。
  • 涉及分钟和秒数——暂时全部以秒为单位便于计算。输出时转换为秒。
  • 如果一个可以被服务的客户都没有,需要直接输出0.0,因为任何数除以0都没有意义。
     
#include<bits/stdc++.h>
using namespace std;
struct node{
	int come,time;
};
bool cmp(node a,node b){
	return a.come<b.come;
} 
int main() {
	int n,k,hh,mm,ss,time,come,sum=0;
	scanf("%d%d",&n,&k);
	vector<node> customer;
	vector<int> windows(k,60*60*8);
	
	for(int i=0; i<n; i++) {
		scanf("%d:%d:%d %d",&hh,&mm,&ss,&time);
		come=hh*3600+mm*60+ss;
		if(come>61200) continue;
		customer.push_back({come,time*60});
	}
	sort(customer.begin(),customer.end(),cmp);
	for(int i=0;i<customer.size();i++){
		int minend=windows[0],minid=0;
		for(int j=1;j<k;j++){
			if(windows[j]<minend){
				minend=windows[j];
				minid=j;
			}
		}
		if(windows[minid]<=customer[i].come) windows[minid]=customer[i].come+customer[i].time;
		else{
			sum+=windows[minid]-customer[i].come;
			windows[minid]+=customer[i].time;
		}
 	}
 	if(customer.size()==0) printf("0.0");
 	printf("%.1f\n",1.0*sum/customer.size()/60);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值