1095 Cars on Campus (30 分)(排序)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

 题意:n条记录,m次询问。每条记录给出车的id,时间,使用状态(in为未使用,out为归还)。每次询问给出某一时刻,求出该时刻有多少辆车在用。

思路:

vector<node> inf: 实时记录每一条信息,时间转换成hh*3600+ff*60+ss

vector<node>car: 判断相邻的两条信息,若id相同并且先in后out就push进car

inf按id排序,id相同按时间排序,map<string,int> mp: 记录车辆id的累计使用时间,维护一个maxtime

car按时间排序,int cnt[i] :记录包括第i辆车在内的之前共有多少辆车

  • if(i==0) cnt[i]=car[i].state;
  • else cnt[i]=cnt[i-1]+car[i].state;

查询的m个时刻按时间顺序给出,为避免不必要的查询,记录上一次查后的位置。

输出mp中所有time==maxtime的车辆id,最后输出maxtime。

#include<bits/stdc++.h>
using namespace std;
struct node {
	string id;
	int time,state;
};
bool cmp1(node a,node b) {
	if(a.id!=b.id)return a.id<b.id;
	return a.time<b.time;
}
bool cmp2(node a,node b) {
	return a.time<b.time;
}
vector<node>inf,car;
map<string,int>mp;
int maxtime=0;
int main() {
	int n,m,hh,ff,mm;
	string state;
	scanf("%d%d",&n,&m);
	inf.resize(n);
	for(int i=0; i<n; i++) {
		cin>>inf[i].id;
		scanf("%d:%d:%d",&hh,&ff,&mm);
		inf[i].time=hh*3600+ff*60+mm;
		cin>>state;
		inf[i].state=(state=="in"?1:-1);
	}
	sort(inf.begin(),inf.end(),cmp1);
	for(int i=0; i<n-1; i++) {
		if(inf[i].id==inf[i+1].id&&inf[i].state==1&&inf[i+1].state==-1) {
			car.push_back(inf[i]);
			car.push_back(inf[i+1]);
			mp[inf[i].id]+=inf[i+1].time-inf[i].time;
			if(maxtime<mp[inf[i].id])
				maxtime=mp[inf[i].id];
		}
	}
	sort(car.begin(),car.end(),cmp2);
	vector<int> cnt(n);
	for(int i=0; i<car.size(); i++) {
		if(i==0) cnt[i]+=car[i].state;
		else cnt[i]=cnt[i-1]+car[i].state;
	}
	int time,tmpid=0,j;
	for(int i=0; i<m; i++) {
		scanf("%d:%d:%d",&hh,&ff,&mm);
		time=hh*3600+ff*60+mm;
		for(j=tmpid; j<car.size(); j++) {
			if(car[j].time>time) {
				printf("%d\n",cnt[j-1]);
				break;
			} else if(j==car.size()-1) printf("%d\n",cnt[j]);
		}
		tmpid=j;
	}
	for(auto it:mp) {
		if(it.second==maxtime)
			cout<<it.first<<" ";
	}
	printf("%02d:%02d:%02d\n",maxtime/3600,(maxtime%3600)/60,maxtime%60);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值