题目描述
Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.
输入
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
输出
For each test case, print S1 - S2 in one line.
样例输入
They are students.
aeiou
样例输出
Thy r stdnts.
解答
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main(void){
string str1;
string str2;
while(getline(cin,str1)){
getline(cin,str2);
for(int i = 0; i < str2.size(); i++)
str1.erase(std::remove(str1.begin(), str1.end(), str2[i]), str1.end());
cout << str1 << endl;
}
}
思路
过程很简单,读取s2字符串中的每一个字符在s1中删除就好,就是如何将字符在string类中删除会有些麻烦,这里用了remove,具体怎么实现的可以不去细究,只需要知道在string中删除某一特定的字符时这样用就可以了,很方便
str1.erase(std::remove(str1.begin(), str1.end(), str2[i]), str1.end())