给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
根据后序遍历确定根,根据中序遍历确定区间。
#include<iostream>
#include<unordered_map>
#include<queue>
#include<vector>
using namespace std;
const int N = 35;
unordered_map<int, int> l, r;
unordered_map<int, int> pos;
vector<int> res;
int postorder[N], inorder[N];
int n;
int build(int pl, int pr, int il, int ir){
int root = postorder[pr]; //找到该段的根节点
int t = pos[root]; //找到根节点在中序遍历的对应下标
if(t > il) l[root] = build(pl, pl+t-1-il, il, t-1); //非空则递归
if(t < ir) r[root] = build(pr-ir+t, pr-1, t+1, ir);
return root; //返回根节点
}
void bfs(int root){
queue<int> q;
q.push(root);
while(q.size()){
auto t = q.front();
q.pop();
res.push_back(t);
if(l[t]) q.push(l[t]);
if(r[t]) q.push(r[t]);
}
}
int main() {
cin >> n;
for(int i = 0; i < n; ++ i) cin >> postorder[i];
for(int i = 0; i < n; ++ i){
cin >> inorder[i];
pos[inorder[i]] = i; //记录中序遍历对应节点的下标
}
int root = build(0, n-1, 0, n-1); //建立二叉树
bfs(root); //层序遍历
cout << res[0];
for(int i = 1; i < n; ++ i) cout << ' ' << res[i];
return 0;
}