PTA刷题日常.1

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 因为数量级限制在10^7次以内,所以采用了比较投机取巧的方法:

源代码如下:

#include<stdio.h>

#include<math.h>

int main(){

int a,b,sum,s;

scanf("%d %d",&a,&b);

sum=a+b;

s=abs(sum);

if(s<1000)

printf("%d",sum);

else if (s<1000000 && s>=1000)

printf("%d,%03d",sum/1000,s%1000);//对取余后位数不够三位的情况,补零

else if(s>=1000000)

printf("%d,%03d,%03d",sum/1000000,(s/1000)%1000,s%1000);

return 0;

}

还有一种方法采用把数字转化为字符串的形式,源代码如下:

#include<stdio.h>

#include<math.h>

int main() {

int a,b,sum,c,i,j,count=0;

char s[9];

scanf("%d%d",&a,&b);

sum=a+b;

c=abs(sum);

if(c<1000) printf("%d",sum);

else {

for(i=0;i<=9;i++)

{ s[i]=sum%10+'0';

sum=sum/10;

count++;

if(sum==0)break;

if(count%3==0)

s[++i]=',';

}

for(;i>=0;i--)

printf("%c",s[i]);

}

return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值