08-图8 How Long Does It Take(25 分)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:
For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.

Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
Sample Output 1:
18
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:
Impossible

###思路:
关键路径问题,以 dist[i] 数组记录到 i 节点的最短时间。以 inDegree[i] 数组记录 i 节点的入度。
每次把入度为零的节点入队,入队之后将该节点指向的节点入度减一。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<queue>
using namespace std;
const int N = 102;
queue<int> q;
int graph[N][N] = { 0 };
int inDegree[N] = { 0 };
int dist[N];
bool topsort(int n) {
	//初始化dist 
	for (int i = 0; i < n; i++) {
		dist[i] = -1;
	}
	int cur = 0;
	for (int i = 0; i < n; i++) {
		if (inDegree[i] == 0) {
			q.push(i);
			dist[i] = 0;
			for (int j = 0; j < n; j++) {
				if (graph[i][j] > 0) {
					dist[j] = graph[i][j];
				}
			}	
		}		
	}

	int cnt = 0;
	while (!q.empty()) {
		cur = q.front();
		q.pop();
		cnt++;
		for (int i = 0; i < n; i++) {
			if (graph[cur][i] >= 0) {
				inDegree[i]--;
				if (dist[cur] + graph[cur][i] > dist[i]) {
					dist[i] = graph[cur][i] + dist[cur];
				}
				if (inDegree[i] == 0) {
					q.push(i);
				}
			}
		}
	}
	if (cnt != n) {
		return false;
	}
	return true;
}
int main() {
	int n, m;
	cin >> n >> m;
	for (int i = 0;  i < n; i++) {
		for (int j = 0; j < n; j++) {
			graph[i][j] = -1;
		}
	}
	while (m--) {
		int s, e, l;
		cin >> s >> e >> l;
		graph[s][e] = l;
		inDegree[e]++;
	}
	
	if (!topsort(n))
		cout << "Impossible" << endl;
	else {
		int max = -1;
		for (int i = 0; i < n; i++) {
			max = max > dist[i] ? max : dist[i];
		}
		cout << max << endl;
	}
	return 0;
}
为了在Windows安装ADB工具,你可以按照以下步骤进行操作: 1. 首先,下载ADB工具包并解压缩到你自定义的安装目录。你可以选择将其解压缩到任何你喜欢的位置。 2. 打开运行窗口,可以通过按下Win+R键来快速打开。在运行窗口中输入"sysdm.cpl"并按下回车键。 3. 在系统属性窗口中,选择"高级"选项卡,然后点击"环境变量"按钮。 4. 在环境变量窗口中,选择"系统变量"部分,并找到名为"Path"的变量。点击"编辑"按钮。 5. 在编辑环境变量窗口中,点击"新建"按钮,并将ADB工具的安装路径添加到新建的路径中。确保路径正确无误后,点击"确定"按钮。 6. 返回到桌面,打开命令提示符窗口。你可以通过按下Win+R键,然后输入"cmd"并按下回车键来快速打开命令提示符窗口。 7. 在命令提示符窗口中,输入"adb version"命令来验证ADB工具是否成功安装。如果显示版本信息,则表示安装成功。 这样,你就成功在Windows安装ADB工具。你可以使用ADB工具来执行各种操作,如枚举设备、进入/退出ADB终端、文件传输、运行命令、查看系统日志等。具体的操作方法可以参考ADB工具的官方文档或其他相关教程。\[1\]\[2\]\[3\] #### 引用[.reference_title] - *1* [windows环境安装adb驱动](https://blog.youkuaiyun.com/zx54633089/article/details/128533343)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insertT0,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [Windows安装使用ADB简单易懂教程](https://blog.youkuaiyun.com/m0_37777700/article/details/129836351)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insertT0,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值