Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
import java.util.*;
public class Main{
static int a,b,num[],st,en;
static A x[];
public static void main(String args[]){
Scanner reader=new Scanner(System.in);
a=reader.nextInt();
b=reader.nextInt();
num=new int[200005];
num[a]=1;
A xx=new A(a,0);
x=new A[200005];
x[0]=xx;
st=0;
en=1;
f();
//System.out.println(num[b]);
}
public static void f(){
for(;;){
A xx=x[st];
st++;
//System.out.println(xx.step+" "+xx.k+" ");
if(xx.step==b){
System.out.println(xx.k);
break;
}
if(xx.step>=1&&num[xx.step-1]==0){
num[xx.step-1]=1;
A y=new A(xx.step-1,xx.k+1);
x[en]=y;
en++;
}
if(xx.step<b&&num[xx.step+1]==0){
num[xx.step+1]=1;
A y=new A(xx.step+1,xx.k+1);
x[en]=y;
en++;
}
if(xx.step<b&&num[xx.step*2]==0){
num[xx.step*2]=1;
A y=new A(xx.step*2,xx.k+1);
x[en]=y;
en++;
}
}
}
}
class A{
int step;
int k;
A(int a,int b){
step=a;
k=b;
}
}