POJ - 3278 Catch That Cow

本文介绍了一种使用广度优先搜索(BFS)算法来解决寻找逃逸奶牛最短路径的问题。Farmer John从点N出发,在同一数轴上找到位于点K的奶牛。通过行走或传送的方式,算法详细展示了如何计算达到目标位置所需的最少时间。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

     

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
       
据说有剪枝  后续更新
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
bool vis[100001];
int step[100001];
queue<int>q;
int bfs(int n,int k)
{
    int head,next;
    q.push(n);//n入队
    step[n]=0;
    vis[n]=true;//标记已访问
    while(!q.empty())
    {
        head=q.front();
        q.pop();//取队首并将其弹出
        for(int i=0;i<3;i++)
        {
            if(i==0)
                next=head-1;
            else if(i==1)
                next=head+1;
            else
                next=head*2;
            if(next<0||next>=100001)
                continue;//判断出界
            if(!vis[next])//如果没有被访问
            {
                q.push(next);//入队
                step[next]=step[head]+1;//步数加1
                vis[next]=true;
            }
            if(next==k)
                return step[next];//结束
        }
    }
}
int main()
{
    int n,k;
    while(cin>>n>>k)
    {
        memset(step,0,sizeof(step));
        memset(vis,false,sizeof(vis));
        while(!q.empty())
            q.pop();
        if(n>=k)
            printf("%d\n",n-k);
        else
        {
            int ans;
            ans=bfs(n,k);
            printf("%d\n",ans);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值