题意解释:
K是多项式非零项的个数
Ni (i~K)是每一项的幂
ai(i~K)是每一项的系数
从样例看来,是Ni为整型,ai为浮点型
注意!!!题目中有要求不能够在最后一项后多输出空格(下面的红色字体部分)
代码比较简单,看看是可以看懂的,然后关于sum的累加,貌似可以不用单独用一个循环来计算,本人在输入样例的时候尝试实现边输入边累加sum,用q[n]-d==0的方法貌似是没有办法优化的,目前想到优化的方法是为每一位设置一个标志位来检测本位是否为0,但是这种方法比较占用空间,而且对于这道题而言并没有必要来专门优化,遂终此题~~~
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
代码如下:
#include<bits/stdc++.h>
#include<iostream>
using namespace std;
const int N=1001;
int k,n,sum,temp;
double d,q[N];
void solve()
{
scanf("%d",&k);
while(k--)
{
scanf("%d",&n);
scanf("%lf",&d);
q[n]+=d;
}
}
int main(int argc,char **argv)
{
int t=2;
while(t--)
{
solve();
}
for(int i=0;i<N;i++)
if(q[i])
sum++;
printf("%d",sum);
for(int i=N-1;i>=0;i--)
{
if(q[i])
{
printf(" %d %.1lf",i,q[i]);
}
}
return 0;
}