HDU-2138 How many prime numbers

Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.

Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

Output
For each case, print the number of prime numbers you have found out.

Sample Input
3
2 3 4

Sample Output
2

简单的求素数个数题 :

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <iomanip>
#include <string>
#include <set>
#include <map>
#include <queue> 
#include <stack>
#include <vector>
#include <algorithm>
#include <sstream> 
#include <cstring>
using namespace std;

bool judge(int x)
{
    for(int i=2;i<=sqrt(x);i++)
    {
        if(x%i==0)
            return true;
    }
    return false;
} 

int main()
{
    int n,t;
    while(cin>>n)
    {
        int ans=0;
        while(n--)
        {
            cin>>t;
            if( judge(t)==false )
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值