【ACM竞赛入门】001.一文读懂常见的ACM题型输入输出格式


本文通过各种类型的A+B题目来帮助大家快速了解ACM题目中常见的输入输出格式,帮助大家快速上手

A+B for Input-Output Practice (I)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate a + b. Too easy?! Of course! I specially designed the problem for acm beginners. You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim

输入格式

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

输出格式

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入

1 5
10 20

样例输出

6
30

AC代码(C语言)

#include<stdio.h>

int main(){
	//freopen("data.in.txt","r",stdin);
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		printf("%d\n",a+b);
	} 
	return 0;
} 

A+B for Input-Output Practice (II)


时间限制: 1s 内存限制: 64MB

题目描述

The first line integer means the number of input integer a and b. Your task is to Calculate a + b.

输入格式

Your task is to Calculate a + b. The first line integer means the numbers of pairs of input integers.

输出格式

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入

2
1 5
10 20

样例输出

6
30

AC代码(C语言)

#include<stdio.h>

int main(){
//	freopen("data.in.txt","r",stdin);
	int a,b,n;
	scanf("%d",&n);
	while(n--){	
		scanf("%d%d",&a,&b);
		printf("%d\n",a+b);
	} 
	return 0;
} 

A+B for Input-Output Practice (III)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate a + b.

输入格式

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

输出格式

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

样例输入

1 5
10 20
0 0

样例输出

6
30

AC代码(C语言)

#include<stdio.h>

int main(){
//	freopen("data.in.txt","r",stdin);
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		if(a==0&&b==0) break;	
		printf("%d\n",a+b);
	} 
	return 0;
} 

A+B for Input-Output Practice (IV)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate the sum of some integers.

输入格式

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

输出格式

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入

4 1 2 3 4
5 1 2 3 4 5
0

样例输出

10
15

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,sum=0,tmp;
	while(~scanf("%d",&n)){
		sum=0;
		if(n==0) break;
		while(n--){
			scanf("%d",&tmp);
			sum+=tmp;
		}
		printf("%d\n",sum);
	}
	return 0; 
}

A+B for Input-Output Practice (V)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to calculate the sum of some integers.

输入格式

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

输出格式

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入

2
4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,m,sum=0,tmp;
	scanf("%d",&n);
	while(n--){
		sum=0;
		scanf("%d",&m);
		while(m--){
			scanf("%d",&tmp);
			sum+=tmp;
		}	
		printf("%d\n",sum);
	}

	return 0; 
}

A+B for Input-Output Practice (VI)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to calculate the sum of some integers.

输入格式

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

样例输入

4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,sum=0,tmp;
	while(~scanf("%d",&n)){
		sum=0;
		while(n--){
			scanf("%d",&tmp);
			sum+=tmp;
		}	
		printf("%d\n",sum);
	}

	return 0; 
}

A+B for Input-Output Practice (VII)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to Calculate a + b.

输入格式

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

输出格式

For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.

样例输入

1 5
10 20

样例输出

6

30

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		printf("%d\n\n",a+b);
	}

	return 0; 
}

A+B for Input-Output Practice(VIII)


时间限制: 1s 内存限制: 64MB

题目描述

Your task is to calculate the sum of some integers

输入格式

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line

输出格式

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

样例输入

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

样例输出

10

15

6

AC代码(C语言)

#include<stdio.h>
int main(){
	//freopen("data.in.txt","r",stdin);
	int n,m,tmp,sum=0;
	scanf("%d",&n);
	while(n--){
		sum=0;
		scanf("%d",&m);
		while(m--){
			scanf("%d",&tmp);
			sum+=tmp;
		}
		printf("%d\n\n",sum);
	}
	return 0; 
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

韩飞雨

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值