题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2104
题目描述:
Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
Output
For each input case, you should only the result that Haha can find the handkerchief or not.
Sample Input
3 2 -1 -1
Sample Output
YES
题目分析:
题意说的是n个人玩找手帕的游戏,每次跳过m-1个人,现在问的就是能否把每个人都找一遍,叫我们求的实际上就是n和m是否互质
AC代码:
#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
using namespace std;
#define LL long long
int gcd(LL a,LL b)
{
return b==0?a:gcd(b,a%b);
}
LL n,m;
int main()
{
while(1)
{
scanf("%lld%lld",&n,&m);
if(n==-1&&m==-1)
break;
if(gcd(n,m)==1)
printf("YES\n");
else
printf("POOR Haha\n");
}
return 0;
}