bestcode Fxx and string

题目描述:

 

Problem Description

Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string SS contains nn lowercase letters S_1S_2\ldots S_nS​1​​S​2​​…Sn​​.Now Fxx wants to know how many three tuple (i,j,k)(i,j,k) there are which can meet the following conditions:

1、i, j, ki,j,k are adjacent into a geometric sequence.

2、S_i=Si​​='yy',S_j=,Sj​​='rr',S_k=,Sk​​='xx'.

3.Either j|i or j|k

Input

In the first line, there is an integer T(1\leq T\leq100)T(1≤T≤100) indicating the number of test cases.

TT lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed 1000010000).

Output

For each case, output the answer.

Sample Input

2
xyyrxx
yyrrxxxxx

Sample Output

0
2

 

 

 

题目分析:

水题,暴力过,注意4,2,1也算是等比数列

 

AC代码:

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=10005;
int T,num;
char s[maxn];


int main()
{
    cin>>T;
    while(T--)
    {
        cin>>s+1;
        num=0;
        for(int i=1;i<=strlen(s+1)/4;i++)
        {
            for(int j=2;i*j*j<=strlen(s+1);j++)
            {
                if((s[i]=='y'&&s[i*j]=='r'&&s[i*j*j]=='x')||(s[i]=='x'&&s[i*j]=='r'&&s[i*j*j]=='y'))
                    num++;
            }
        }
        cout<<num<<endl;
    }
    return 0;
}

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值