题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1081
题目描述:
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
题目大意:
在一个n*n的矩阵中,找到一个子矩阵,使得和最大
题目分析:
同找最大和子序列,只是把二维变一维,用到了状态压缩,这里我把列压缩
AC代码:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int dp[105][105];
int main()
{
int n,num;
while(scanf("%d",&n)!=EOF)
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
scanf("%d",&num);
dp[i][j]=dp[i][j-1]+num;//代表第i行第一个数字到第j个数字的和
}
}
int Max=-0xfffffff,sum=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<i;j++)//i j 之间的列数的和当做整体
{
sum=0;
for(int k=1;k<=n;k++)//k行
{
if(sum<0)
{
sum=0;
}
sum+=(dp[k][i]-dp[k][j-1]);
if(sum>Max)
{
Max=sum;
}
}
}
}
cout<<Max<<endl;
}
return 0;
}