1009 Product of Polynomials (25 point(s))
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 a**N1 N2 a**N2 … N**K aNK
where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
#include <iostream>
#include <cstdio>
using namespace std;
int main(){
int k1,expo1[10];
double coef1[10];
cin>>k1;
for(int i=0;i<k1;i++){
cin>>expo1[i]>>coef1[i];
}
int k2,expo2[10];
double coef2[10];
cin>>k2;
for(int i=0;i<k2;i++){;
cin>>expo2[i]>>coef2[i];
}
double polyno[2001] = {}; //因为0才是第一个遍历的位置,所以结尾位置是2000的话,大小要设置为2001
for(int i=0;i<k1;i++){
for(int j=0;j<k2;j++){
polyno[expo1[i]+expo2[j]]+=coef1[i]*coef2[j];
}
}
int sum=0; // 这里一定要分配初始值
for(int i=0;i<=2000;i++){
if(polyno[i]!=0) sum++;
}
cout<<sum;
for(int i=2000;i>=0;i--){
if(polyno[i] != 0){
printf(" %d %.1f",i,polyno[i]); // 注意这里 .1f 小数点
}
}
}