1009 Product of Polynomials (25 point(s))

1009 Product of Polynomials (25 point(s))

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
#include <iostream>
#include <cstdio>

using namespace std;

int main(){
    
    int k1,expo1[10];
    double coef1[10];
    cin>>k1;
    for(int i=0;i<k1;i++){
        cin>>expo1[i]>>coef1[i];
    }
    int k2,expo2[10];
    double coef2[10];
    cin>>k2;
    for(int i=0;i<k2;i++){;
        cin>>expo2[i]>>coef2[i];
    }
    double polyno[2001] = {};  //因为0才是第一个遍历的位置,所以结尾位置是2000的话,大小要设置为2001
    for(int i=0;i<k1;i++){
        for(int j=0;j<k2;j++){
            polyno[expo1[i]+expo2[j]]+=coef1[i]*coef2[j];
            
        }
    }
    
    int sum=0;  // 这里一定要分配初始值
    for(int i=0;i<=2000;i++){
        if(polyno[i]!=0) sum++;
    }
    cout<<sum;
    
    for(int i=2000;i>=0;i--){
        if(polyno[i] != 0){
            printf(" %d %.1f",i,polyno[i]); // 注意这里 .1f 小数点
        }
    }
    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值