a1063 Set Similarity (25 分)

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题意:

输入分两部分:

1.多组数据,每组数据分别输入:该组的数据数量,每个数据

2.多组数据,分别输入该组要比较的两个set


思路:

要求的是两个set相同的数字所占比例,设两个set为s1,s2,两个set合并后为s3,那么这个比例可以表示为:(s1.size()+s2.size()-s3.size)/s3.size()

1.利用set<int> s[55]将每组数据存入数组

2.创建中间用于比较的set t0.


注意:

1.每次t0都要clear一下

2.注意最后保留一位小数且使用百分数形式表示


ac代码:

#include<iostream>
#include<set>
#include<iomanip>
using namespace std;
int main(){
	int n,a,b,x,y,s1,s2,t0;
	cin>>n;
	set<int> s[55];
	set<int> t;
	for(int i=1;i<=n;i++){
		cin>>a;
		for(int j=0;j<a;j++){
			cin>>b;
			s[i].insert(b);
		}
	}
	cin>>a;
	for(int i=0;i<a;i++){
		cin>>x>>y;
		s1=s[x].size();
		s2=s[y].size();
		t.insert(s[x].begin(),s[x].end());
		t.insert(s[y].begin(),s[y].end());
		t0=t.size();
		cout<<setiosflags(ios::fixed)<<setprecision(1)<<(double)(s1+s2-t0)*100/t0<<"%"<<endl;
        t.clear();
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值