树形dp hdu1520

Anniversary party

 HDU - 1520 

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意:给一棵树,选最多的结点使得选择的结点不存在直接的父子关系

很容易想到一个结点有两个状态:选子节点或者不选

初始化自然是叶子结点dp[u][0]=0,dp[u][1]=w[u]

u不选的时候:u的儿子可以任意选或者不选,所以dp[u][0]+=max(dp[v][0],dp[v][1])

u选的时候:u的儿子一定不能选,所以在一开始状态上加上不选u儿子的状态dp[u][1]=w[u] + dp[v][0]

答案自然就是max(dp[rt][0],dp[rt][1])了

#include<bits/stdc++.h>
using namespace std;
const int maxn = 6e4 + 5;
const int maxnn = 1e5 + 5;
int tot = 0;
int n;
int first[maxn];
int w[maxn];
int dr[maxn];//记录入度
int dp[maxn][2];
struct node{
	int e, next;
	node(){}
	node(int a, int b):e(a),next(b){}
}edge[maxnn];
void init(){
	tot = 0;
	memset(first, -1, sizeof(first));
	memset(w, 0, sizeof(w));
	memset(dp, 0, sizeof(0));
	memset(dr, 0, sizeof(dr));
}
void addedge(int u, int v){
	edge[tot] = node(v, first[u]);
	first[u] = tot++;
}
void dfs(int rt){
	dp[rt][0] = 0;
	dp[rt][1] = w[rt];
	for(int i = first[rt]; i != -1; i = edge[i].next){
		int v = edge[i].e;
		dfs(v);
		dp[rt][0] += max(dp[v][1], dp[v][0]);
		dp[rt][1] += dp[v][0];
	}
}
int main(){
	while(~scanf("%d",&n)){
        init();
        for(int i = 1; i <= n; i++) scanf("%d",&w[i]);
        int u, v;
        while(1){
            scanf("%d%d", &v, &u);
            if(!v && !u) break;
            addedge(u, v);
			dr[v]++;
        }
        int root;
        for(int i=1;i<=n;i++) if(dr[i] == 0){
            root = i;
        }//取入度为0的点入度为0即为根节点
        dfs(root);
        printf("%d\n",max(dp[root][0],dp[root][1]));
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值